Scooter Review: 2009 Kymco People 150

Back at the beginning of this year, I bought a new scooter. Needless to say, I formed some pretty strong opinions about the new machine within the first couple of weeks. I restrained myself from writing a review right away, though. I though it would mean more after I put a thousand miles or so on it. This morning I looked down at my odometer and saw 1749 km, which works out to about 1050 miles.

I chose a 150cc scooter because it is big enough to go 60 mph on arterial streets, but small enough to be fuel efficient and easy to park. There are hundreds of models of 150cc scooters on the market. I chose a Kymco because they have a reputation as a reputable company, with offices in the US and a 2 year warranty. Kymco makes a lot of the fact that they use ISO 9001 quality control. I thought that a Kymco would be reliable “out of the box”.

If I had it to do over, I would still buy a 150cc scooter, but probably not a Kymco.

First, the good:

The scooter handles great. It points well, and the front-back balance is as good as any motor bike I’ve owned. The wheels are big (16″), which helps a lot on the crappy blacktop we have here in Los Angeles. Kymco seems to use a better grade of hoses and lines than most of the mainland scooters. The carburetor and other parts are made by vendors whose names I actually recognized.

The luggage rack, which looks like it would be small and useless, is surprisingly handy. I do wish, though, that they had made it out of metal. The paint is already wearing off of the plastic. Then again, I haul a lot more cargo with my scooter than most American’s, because I do not own a car.

Now the bad:

From the beginning, the scooter has had an annoying and dangerous habit of stalling unexpectantly in traffic. Initially, I tried to get it fixed under warranty. The clueless dealer called Kymco and was told that I, the owner, had probably over-filled the gas tank and swamped the evaporative emissions canister. Kymco send out a new canister, which did not fix the problem. the mechanic mentioned that KymcoUSA is “sort of hard to deal with”.

Apparently many California-model Kymcos have fuel system issues because of the after-thought nature of the emissions system. It occurs to me that if the gas-tank vent line were to vibrate off the check valve, then the problem would go away with no noticeable decrease in performance… Get it? Got it? Good.

My own problem had nothing to do with the fuel system, however. Once I gave up on the dealership and the warranty process, I eventually tracked it to a defective CDI module that was overheating. So much for ISO 9001 quality control. I put on a $25 generic module that seems to have fixed the problem. All in all, my new scooter was unreliable and dangerous for about four months while I spent hours working on it.

Next time, I will just get one of the cheap no-name scooters. I’ll probably still need to spend a few weeks fixing the bugs, but it will cost about 1/3 the price. I paid a lot of extra money for a scooter that I thought I would not have trouble with, and that money was wasted.

That being said, the scooter is working out for me now. I’ll probably keep it for at least a couple of years before I trade it off.

18 comments

  • Hi, thanks for the review. Way to track down the defective CDI on your own, sounded like a challenge.So I’m wondering how your P150 is doing now since you posted in April. I am considering buying one even though I would probably have to replace the CDI. (Btw, do you know if all CDIs have rev limiters in them?)On another note, is there any danger to removing the gas vent line like you recommend? For instance, if you fill the tank to the brim, will gas spew from the line as there is no air at that point to vent? Not exactly sure how that system works.Btw, I’m interested in reading your “chilling” research paper about “the environmental problems of recycling batteries.” Do you have it posted online somewhere?Thanks again- Roy

  • Having owned a People 150 for a couple years, I would say that you just got a lemon. It happens. Mine ran flawlessly through bumpy D.C. city streets and traffic and on highways, in 100+ degrees, below-freezing temperatures, and in a torrential downpour. I was so pleased with Kymco’s quality that, two scooters later, I’ve gone back to Kymco. I’m now 7,500+ miles into daily commuting 75 miles (one way) on a Downtown 300i without a problem.

  • My 2009 Kymco People 150 has been stalling off and on at 35 to 40 miles and hour. I had it towed to the dealer, because I was afraid to ride it. The dealer rode it and could not replicate the problem, so $167.00 later I still had the same issue. I called Kymco myself and the technician told me that the evaporative emissions canister was the culprit. Kymco said they’d cover it. After reading your comment, I’m not so sure the evaporative emissions canister is the issue. It’s a shame, because I bought a Kymco for the same reason: relaibilty, warranty, and quality.

  • Did your scooter restart immediately? Mine stalls, but won’t restart until later. Not sure how much longer because I usually need to find alternate transportation and don’t try to restart until hours later.

  • Did your scooter immediately restart? I have a similar problem, but when it stalls, it does not restart.

  • Lieiti, there shouldn’t be any problem pulling that extra tubing, given that it doesn’t even exist on the non-California model. If you then overfill your gas tank it will spill over and make a mess, so don’t do that. It will not, however, damage anything on our bike.

  • Dunmary311, mine would usually start after I let it cool for a minute or two. After that it would run until it got hot again (anywhere from a couple blocks to a couple miles).

  • UPDATE ON THE SCOOTER: My scooter got stolen after I had only owned it for six months. It was parked in the driveway outside my building with the steering locked. I’m guessing a gang of guys just picked it up and put it in a van or something. I should have embedded an eye-bolt in contrete and bought a BIG chain for it. (About the size they use for the anchors on destroyers) It was too damn bad, because I had finaly gotten it running perfectly… Since then I have been mainly getting around on foot.

  • mjoel

    After the dealer disengaged, or fixed the evaporative emissions canister my People 150 has been running great. I forgot to mention that when the scooter did stall, I was instructed to rmove the gas cap to relieve pressure. This usually helped and the scooter would start.

  • Anonymous

    My CDI was good but I did have a similar problem.To fix it I removed the gas cap and drilled the tiniest hole possible in the center of the gas cap. It’s been any years and it’s never stalled again.Best bet – find a group on the Internet that owns the same scooter as you. They’ll know the answers.

  • Kymco Scooters are really wonderful and always unique design. I have been using kymco scooter since 2010.

  • Anonymous

    I’m in Austin. Bought 2008 people 150 new. Drove it every day for three years. Never had a problem. But now it has sat for over a year. Of course it won’t start. I need to clean carb and injectors. But HOW. Book? Video?

  • Carburetors have jets, not injectors. A large one and a small one in this case. Just take off the carb and take the bottom off. take it apart until you can see the jets, paying attention to how things go together. Spray the heck out of the jets with a can of carb cleaner. Put everything together the way you found it. If you get stuck, Google “keihin carburetors diagram” for many pictures. This is a good one to learn on. People in my generation had to cut our teeth on 4-barrel car carbs, which have about 5 times as many moving parts and were usually worn out by the time we got them.

  • I have had two P150’s. One is a 2006 and the other is a 2012. The only trouble I ever have is with the fuel sending unit. I have run out of gas because the fuel gauge says 1/4 tank when I am actually on fumes. I have to be really careful to fill up at 150km. As insurance, I bought a MSR fuel canister and carry it under the seat.

  • Got a query, stalled vs. pressure drop. I have a Kymco 200cc and as of late when I drive it at a steady 55-60 after about 10 miles it begins sputtering and drops in pressure to about 25-35. I give it all the gas I can, and it tops out at 35, I end up pulling off the highway. I wait about 10 minutes and I’m good to go again, but this time for only another 3 miles before it all starts again. It does not stall, i.e., shut off. And during my break, it starts right back again. My dealer can’t figure it out and I am in Austin, so not sure the bike has any emissions. I’ve had the bike since new and it only has 1500 miles on it.Thought?Kathy

  • Kathy, Two possibilities come to mind, off hand:1) You have a faulty ignition coil. Bad coils often get wonky when they get hot. It is more common for them to cut completely, but sometimes they can produce the effect that you’re describing. You can often find aftermarket coils for these bikes on the net for under $20, so it might be worth swapping out just to see (should only require a screwdriver).2) Your fuel system isn’t venting properly. If this is the case, then once the bike runs for a while and builds up suction in the tank it would run crappily. Try running it with the cap loose to it can breath, and see of the problem persists. If so, you might need to cut a small vent hole in the gas cap (can easily be done with a little bitty drill bit.). Those are probably the two things I would explore first. I hope that helps.

  • My 2013 Kymco 150 won’t start in cold weather (50deg F). If I warm it up with a heat gun it will start. Otherwise it starts and runs fine. I’m guessing it’s the automatic choke. Has Anyone else found a solution to this?

  • Uncommon,I never had problems with my Kymco in that sort of weather (50 deg really isn’t that cold). But I had a Honda back in the day that I used to choke on cold mornings by shoving my glove part way in the air intake. Not elegant, but sometimes the simple solutions work best (although my fingers did get cold until I could retrieve the glove…)The GY6 carb uses an electric choke. I would test the solenoid. If its bad, you can get one pretty cheaply on the web.

Leave a Reply

Your email address will not be published. Required fields are marked *